Welcome Guest... Login?
 
 
 « BACK Ice Fishing Forum

FishnCanuck

HELP!!! Eskimo 10" Auger Problem


When I try to cut holes, I need to lean on the power head to keep it cutting ice. I thought the blades were dull and took them in for exchange and the shop said mine were as sharp as the refurb sets he had there. There was some thought that the power head was bad, but when I switched to a buddy's 8" shaft, it cut fine.

The only thing I can figure now is that somehow the 10" shaft I have got warped/bent on LOW last march with the extension attached.

Anyone have ideas on what the problem is and where I can get it fixed. It's 5yrs old so Ardisam probably won't warrant anything but it's worth a shot if I can't find a local repair option.

Thoughts???

--------------------
Good Luck!

FishnCanuck
_______________________________________

Set the Hook and Get the Net!


Calvin Svihel

Re: HELP!!! Eskimo 10" Auger Problem


Have you ever drilled a hole part of the way and left your auger standing upright in the uncut hole? I know the guys at strikemaster don't suggest this because it can change the form of the auger and not allow it to cut correctly.

You can always just buy a new auger, since your powerhead is working fine.

--------------------



Ryno

Re: HELP!!! Eskimo 10" Auger Problem


It sounds like you bent the blades out of pitch... When a auger blades start to dull our first instinct is to push down on the auger with our weight. They are not designed to take those kinds of forces. Using an extension wouldn't do this. Call Ardisam and see if you can send the auger (not the power head) to be retuned/straightened out. I am sure they will help you out. It actually happens quite often.

--------------------
Dedication, Inspiration, Motivation....
For me, fishing is more of an Obsession.


FishnCanuck

Re: HELP!!! Eskimo 10" Auger Problem


Thanks for the quick response Calvin. Any ideas where in the metro a guy can pick one up (new or used)?

--------------------
Good Luck!

FishnCanuck
_______________________________________

Set the Hook and Get the Net!


Ryno

Re: HELP!!! Eskimo 10" Auger Problem


I really think eskimo will help you out. It is worth a try anyway. It might cost you to ship it there but you'll have to call them to be sure. It would be cheaper then buying a new auger for it I would think.

Edited by Ryno (01/07/09 09:59 PM)


FishnCanuck

Re: HELP!!! Eskimo 10" Auger Problem


Ryno,

I haven't left the Auger in the hole, but I was worried the bouncy 25 mile sled rife back and forth to Oak Island for 4 days might have done it in.

--------------------
Good Luck!

FishnCanuck
_______________________________________

Set the Hook and Get the Net!


Ron W Basser2

Re: HELP!!! Eskimo 10" Auger Problem


Glad to hear the answers on this because my eskimo is doing the same thing. I just put on new blades and the only way it cuts is to lean on it.

Somebody told me the cutting point was not sharp, anyone heard of that?

Thanks.


Ryno

Re: HELP!!! Eskimo 10" Auger Problem


Just wondering... are they Qantum blades or turbo blades?
It could be a cutting point too... they fall out alot... if you replace it loc=tite will be your best freind.

Edited by Ryno (01/07/09 10:09 PM)


Castaway

Re: HELP!!! Eskimo 10" Auger Problem


Could be a couple of things.Blades iced up or out of pitch or dull blades.If you bent something new blades may not help but I would start with new blades first and go from there.

--------------------
Most of the worlds problems can be solved with common sense,the rest may require a little gun powder.


BIRDDOG

Re: HELP!!! Eskimo 10" Auger Problem


My 10" Barracuda did the same exact thing. I tried 2 sets of blades, didn't help, couldn't tell by eye but somehow the blade mount got tweaked. I bought a new 8"(bit), problem solved. I don't think you'll be able to tweak it back into shape...that angle is so fine you'll never get it back again.

I called Ardisam when this happened, they wouldn't warranty it, wanted to soak me for a new bit$$$...I think I paid $60 for a new 8" off Ebay.

BIRDDOG

--------------------
FOR BETTER OR WORSE, FISHING AND HUNTING COME FIRST


FishnCanuck

Re: HELP!!! Eskimo 10" Auger Problem


Thanks birddog,

That's what I expected. I'll start kooing for a new shaft (bit).

--------------------
Good Luck!

FishnCanuck
_______________________________________

Set the Hook and Get the Net!


BIRDDOG

Re: HELP!!! Eskimo 10" Auger Problem


I purchased mine through the seller (tc-store) on Ebay.

They were the cheapest I could find anywhere, might want to look them up. Good luck.

BIRDDOG

--------------------
FOR BETTER OR WORSE, FISHING AND HUNTING COME FIRST


Wes

Re: HELP!!! Eskimo 10" Auger Problem


The tip must be sharp.If it is and still dont cut,you could try a thin shim under the blade's. Put the shim next to the bolts on the dull side,this will tip the cutting edge down, making it cut more.

SAUGER

Re: HELP!!! Eskimo 10" Auger Problem


Look closly were the blade mount meets the hoop.I have had mine crack causing one of the blades to flex so only one side was cutting.

--------------------
Whoever said laughter is the best medicine;obviously never had GONORRHEA

I'm no gynecologist but I'll take a look!


Chris Tuckner

Re: HELP!!! Eskimo 10" Auger Problem


Quote:

Look closly were the blade mount meets the hoop.I have had mine crack causing one of the blades to flex so only one side was cutting.




I had this happen a couple of years ago as well.


Copyright In-DepthOutdoors.com, Inc. 2001 - 2014, All Rights Reserved.