Welcome Guest... Login?
 
 
 « BACK ATVs & Snowmobiles

MTHank

Polaris ATV... Shuts off at 4,000 RPM's


I have a 2005 Polaris Sportsman 500 HO that loses power (shuts off) anytime you get it to 4,000 RPM's. This happened all of a sudden. An example is like in reverse when and you try to go too fast and it has a built in governor and it shut the ignition off (I think). But once in a while it runs OK.

I think I also have a fuel pump problem How much volume should the fuel pump put out at idle and what kind of pressure should it have (if any, that is)?

Thanks for any help...
MTHank in Montana


big G

Re: Polaris ATV... Shuts off at 4,000 RPM's


Not sure Hank, I have a 700 and haven't had that issue.... I see your from MT, do you fish Flathead much ??? I have never been that far out there, but a buddy I used to work with, lives in Polson and has invited me out many times to fish Flathead, but have never went. I know he does pretty well fishing the lake

--------------------
big G

You can tell how big a person is, by what it takes to discourage them! "Hooks"




putt2winn

Re: Polaris ATV... Shuts off at 4,000 RPM's


One idea, stuck choke. Would run until gets to rich. Might also explain your fuel pump question. Check the linkage on the carb when you engage the choke and see if it moves back all the way when you disengage. Manually pull the choke linkage back on the carb after starting to see if it fully turns "off". If it runs good until 4000 rpm and does not bog not likely choke. Could be fuel pump. Check the wires. Oil level good? Not an overheat piston issue?

--------------------
I once thought I might be wrong, However I was only mistaken.

Edited by putt2winn (05/26/11 12:05 AM)


Copyright In-DepthOutdoors.com, Inc. 2001 - 2014, All Rights Reserved.